Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Had some issues with Autopilot, want to share how i fixed them!

Joined
Oct 7, 2015
Messages
2
Reaction score
1
Age
35
Actually, Autopilot is not the one to blame, but using it before the DJI GO app .

So the thing is that i updated to latest fw (1.3 for remote and 1.4 for aircraft), and did NOT run an IMU calibration afterwards.

I went to fly, and started the DJI GO app to exit travel mode, then closed the app, shut down the aircraft, and attached the gimbal.

After this, i started the Autopilot app, and added zipline to it. I was getting several warnings about the GPS position (using iPad mini 3), until everything appeared to be ok. I set the height to 30m for both points, then engaged the craft.

I noticed that it was flying up and not stopping, to a point i almost lost sight. Then i realized that the craft "height" was zero in the app! I would say that when i switched to manual control (F), it was already above 100m. I started to bring down the aircraft, and was able to land it manually.

After this, i thought it would be a good idea to restart the aircraft, so i powered it down, and then up. It was then not willing to take off, but not making any kind of sounds or warnings, so i decided to close the Autopilot and open the DJI Go app.

There, i got two errors: "MC connection to center board failed", and "IMU calibration needed". The aircraft started to continuously beeping twice also after a few seconds of rebooting, and the camera would seem to "die" (though it still provided video feedback). I tried everything while at the field, like cleaning contacts, cleaning pins, making sure that gimbal cables were properly attached, calibrate IMU (which didnt move from 0%)... but nothing worked.

So, i decided to get back home, and there i assembled again the craft with the gimbal. This time i would only get the IMU calibration error. I just tried to calibrate IMU again, and this time it would work. After it was done, the aircraft had no more errors.

I still need to check it on a real flight, but it looks good now.


Lessons learned:

  • After a firmware update, ALWAYS calibrate compass and IMU thru DJI Go app.
  • Do NOT use Autopilot app right after a firmware update!

Hope this helps to anyone with similar or same issue!

PS: Yes, i know you guys will eat me alive with the "why didnt you calibrate IMU after update?" :p
 
  • Like
Reactions: avago1

The Editor

Moderator
Staff member
Joined
Aug 7, 2013
Messages
10,206
Reaction score
5,349
Actually, Autopilot is not the one to blame, but using it before the DJI GO app .

So the thing is that i updated to latest fw (1.3 for remote and 1.4 for aircraft), and did NOT run an IMU calibration afterwards.

I went to fly, and started the DJI GO app to exit travel mode, then closed the app, shut down the aircraft, and attached the gimbal.

After this, i started the Autopilot app, and added zipline to it. I was getting several warnings about the GPS position (using iPad mini 3), until everything appeared to be ok. I set the height to 30m for both points, then engaged the craft.

I noticed that it was flying up and not stopping, to a point i almost lost sight. Then i realized that the craft "height" was zero in the app! I would say that when i switched to manual control (F), it was already above 100m. I started to bring down the aircraft, and was able to land it manually.

After this, i thought it would be a good idea to restart the aircraft, so i powered it down, and then up. It was then not willing to take off, but not making any kind of sounds or warnings, so i decided to close the Autopilot and open the DJI Go app.

There, i got two errors: "MC connection to center board failed", and "IMU calibration needed". The aircraft started to continuously beeping twice also after a few seconds of rebooting, and the camera would seem to "die" (though it still provided video feedback). I tried everything while at the field, like cleaning contacts, cleaning pins, making sure that gimbal cables were properly attached, calibrate IMU (which didnt move from 0%)... but nothing worked.

So, i decided to get back home, and there i assembled again the craft with the gimbal. This time i would only get the IMU calibration error. I just tried to calibrate IMU again, and this time it would work. After it was done, the aircraft had no more errors.

I still need to check it on a real flight, but it looks good now.


Lessons learned:

  • After a firmware update, ALWAYS calibrate compass and IMU thru DJI Go app.
  • Do NOT use Autopilot app right after a firmware update!

Hope this helps to anyone with similar or same issue!

PS: Yes, i know you guys will eat me alive with the "why didnt you calibrate IMU after update?" :p
Hi and welcome to the forum.
Glad you sorted your problem and lesson learned ........

This is why I have always advocated all over this forum to do a three way calibration every time you update firmware.
  • IMU calibration
  • Compass calibration (in a known good area)
  • Stick calibration
The reason you probably could not get the IMU to calibrate in the field is that the flight controller was already warm from prior use.
It is always best to do an IMU Cali immediately after turning the aircraft on so that everything g is cold.
 
Joined
Oct 7, 2015
Messages
2
Reaction score
1
Age
35
Thanks!

I just came back from a test flight with Autopilot, and now everything is working perfectly.
 

New Threads

Members online

Forum statistics

Threads
20,188
Messages
196,230
Members
29,649
Latest member
mike " Bandit"